YogiS
28.12.2020, 12:42

Editiert von
YogiS
30.12.2020, 11:36

Mindstorms Robot Inventor per Bluetooth an Windows 10 Problem [gelöst]

Hallo,
Ich habe ein Problem mit der Robot Inventor App unter Windows 10.
Die App baut per BT eine Verbindung mit dem Hub auf und kann die Sensordaten auslesen. Dann kommt eine Meldung, dass ich den Hub aktualisieren soll. Das funktioniert auch. Also werden Daten zum Hub gesendet. Nach der Installation zeigt die App live die Sensordaten an. Wenn ich z.B. meine Hand an den Nährungssensor halte dann ändert sich auch die Anzeige in der App.
Versuche ich aber ein Programm zum Hub zu schicken passiert erstmal gar nichts. (selbst eine Art Hallo Welt geht nicht)
Dann friert die App ein und nach einigen Minuten meldet mir die App "etwas ist Schiefgelaufen". Was da "Schiefgelaufen" ist sagt sie mir nicht.
Mit dem Kabel geht es einwandfrei. Nur ist es doof das ganze mit Kabel zu machen, weil die Beispiel-Apps die mein Sohn durchspielen möchte mit Kabel nur bedingt funktionieren weil sich der Hub auf dem Roboter nunmal direkt nach Upload bewegen soll und das Kabel dabei stört.

Was habe ich schon alles Probiert:
- App neu installiert
- Hub zurückgesetzt
- BT Treiber neu installiert (vorher Restlos entfernt)
- Alternative BT Treiber für Windows 10 installiert.
- alle anderen BT Geräte in der Umgebung deaktiviert.

[image]



Leider habe ich im Internet noch kaum Informationen zum Robot Inventor gefunden. Ich kann ihn leider auch nicht mit Skratch verbinden. Da die Programmierung auf dem Handy quasi nicht möglich ist (es ist einfach zu klein) können wir den bisher eigentlich nur die Beispiel Blocks aus der App laufen lassen.

Hat jemand eine Idee was ich noch probieren könnte?
VG
Jörg



Technicmaster0
28.12.2020, 13:41

Als Antwort auf den Beitrag von YogiS

Re: Mindstorms Robot Inventor per Bluetooth an Windows 10 Problem

Permalink

1000steine-Code

BBCode

HTML


Ist der Hub im Streaming Modus oder im Download-Modus? Das kann man rechts unten kontrollieren indem man auf den "Speicherplatz" drückt.



YogiS
28.12.2020, 15:00

Als Antwort auf den Beitrag von Technicmaster0

Re: Mindstorms Robot Inventor per Bluetooth an Windows 10 Problem

Technicmaster0 hat geschrieben:

Ist der Hub im Streaming Modus oder im Download-Modus? Das kann man rechts unten kontrollieren indem man auf den "Speicherplatz" drückt.


Ich habe beide Modi ausprobiert. Im Downloadmodus kommt "etwas ist schiefgelaufen" egal auf welchem Speicherplatz. Schaut man sich die gespeicherten Programme an sieht man das neue Programm im Hub. Allerdings ist es nicht Ausführbar. Es ist auch nur ein Byte groß. Also unvollständig.
Im Streamingmodus passiert nichts.



Technicmaster0
30.12.2020, 10:33

Als Antwort auf den Beitrag von YogiS

Re: Mindstorms Robot Inventor per Bluetooth an Windows 10 Problem

Welche Standards nutzt der Bluetooth Adapter bzw wie alt ist er?



YogiS
30.12.2020, 11:30

Als Antwort auf den Beitrag von Technicmaster0

+1Re: Mindstorms Robot Inventor per Bluetooth an Windows 10 Problem

Technicmaster0 hat geschrieben:

Welche Standards nutzt der Bluetooth Adapter bzw wie alt ist er?


Der BT Adapter ist 4 Jahre alt. Der andere PC den ich genutzt habe ist 3 Jahre alt. Treiberstand ist aber aktuell.
Ich habe das Problem gestern gelöst.

Vielleicht dient dieser Workaround dem ein oder anderen als Hilfe:

Ursache lag wohl in dem Hub, offensichtlich hat das Firmwareupdate ihn zerschoßen.
Lösen konnte ich es ehr zufällig. Ich habe versucht mit der Software für den Lego EDU Spike (der Hub ist Baugleich) eine Verbindung aufzubauen.
Die SpikeApp hat dann noch ein Firmwareupdate durchgeführt. Dort hat dann alles funktioniert.
Nach einem Test in Spike habe ich dann wieder auf die RobotInventor App gewechselt.
Diese hat dann wieder ein Firmwareupdate durchgeführt. Seid dem funktioniert alles wie es soll.

Vielen Dank für eure Mühe
Jörg



AdmiralStein gefällt das


Technicmaster0
30.12.2020, 13:07

Als Antwort auf den Beitrag von YogiS

Re: Mindstorms Robot Inventor per Bluetooth an Windows 10 Problem [gelöst]

Das ist gut zu hören. Ja, der Updatevorgang ist etwas unstabil



jackjakoby
30.01.2021, 15:06

Als Antwort auf den Beitrag von YogiS

Re: Mindstorms Robot Inventor per Bluetooth an Windows 10 Problem

Servus YogiS,

gemäß deiner Beschreibung hab ich das gleiche Problem wie du (gehabt hast).
Leider hab ich keine Spike Möglichkeit und da stellt sich die Frage, wie ich den HUB reseten/zurücksetzen/neu laden kann?
In der Beschreibung ist nur ein Update möglich, wenn es im Windowsprogramm angezeigt wird (... wird von Zeit zu Zeit oben rechts in der App eine Meldung angezeigt...).

Vielen Dank für eine Hilfestellung!

LG




YogiS hat geschrieben:

Technicmaster0 hat geschrieben:
Welche Standards nutzt der Bluetooth Adapter bzw wie alt ist er?


Der BT Adapter ist 4 Jahre alt. Der andere PC den ich genutzt habe ist 3 Jahre alt. Treiberstand ist aber aktuell.
Ich habe das Problem gestern gelöst.

Vielleicht dient dieser Workaround dem ein oder anderen als Hilfe:

Ursache lag wohl in dem Hub, offensichtlich hat das Firmwareupdate ihn zerschoßen.
Lösen konnte ich es ehr zufällig. Ich habe versucht mit der Software für den Lego EDU Spike (der Hub ist Baugleich) eine Verbindung aufzubauen.
Die SpikeApp hat dann noch ein Firmwareupdate durchgeführt. Dort hat dann alles funktioniert.
Nach einem Test in Spike habe ich dann wieder auf die RobotInventor App gewechselt.
Diese hat dann wieder ein Firmwareupdate durchgeführt. Seid dem funktioniert alles wie es soll.

Vielen Dank für eure Mühe
Jörg