reckless_glitch
28.05.2022, 15:12

Editiert von
reckless_glitch
05.06.2022, 10:33

+8Ferngesteuert: DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

Endlich gibt es einen vernünftigen DeLorean von LEGO
Nachdem ich schon den ECTO, die Tumbler und das 1989er Batmobil motorisiert hatte,
hab ich mir auf Verdacht den DeLorean am 1.4 im LEGO Laden gekauft und siehe da, es passen Motoren rein.

Powered up Motorisierung und Fernsteuerrung für den 10300 DeLorean

Es war eine ganz schöne Odyssee, herauszufinden, welche powered up Komponenten eigentlich zusammenpassen:
Den L-motor als antrieb mit nem kleinen powered up hub? vergesst es, der Hub hängt sich auf, vermutlich, weil der L-Motor zu viel Strom zieht für die AAA Bateriien im hub. Der bräuchte wohl lipos.
Jedenfalls hab ich es dann mit dem Buwizz und 2x Large Motor gelöst.


★ BAUANLIETUNG

Findet ihr auf rebrickable wie immer.

► ferngesteuertes Fahren und lenken
► Cockpit unverändert
► kann immernoch für Teil 1- Teil 3 Modifiziert werden (2 in 1 LEGO set)
► Buwizz leicht zu erreichen zum einschalten oder laden
► Die Veränderrungen sind kaum zu sehen (die räder klappen nicht mehr runter)
► dezenter fix für die Flügeltüren, damit die göffnet bleiben können (hatte LEGO wohl vergessen ;) )
► LED light kit passt rein (rabatt code in der Anleitung)
► werde noch eine Beschreibung mit rein tun, wie man die LEDs über den Buwizz mit strom versorgt
► Mehrsprachige Bauanleitung: ►english ►deutsch ►italiano ►française ►español ►čeština ►русский
► Der Partfinder: Hilft beim Finden von woanders verwendeten Steinen, ohne immer alle Tüten durchwühlen zu müssen
► Buwizz Programmierung

[image]





Seeteddy , AdmiralStein , celticdragon , Micha2 , Technix , ThomaS , BRUNO , tastenmann gefällt das (8 Mitglieder)


10 vorhergehende Beiträge sind ausgeblendet

Alle anzeigen Immer alle anzeigen Beitragsbaum

reckless_glitch
05.06.2022, 10:52

Als Antwort auf den Beitrag von Technicmaster0

Re: Ferngesteuerte DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

Technicmaster0 hat geschrieben:

Lok24 hat geschrieben:
Ja, den Bug habe ich mit Video im Januar 2020 (!) bei LEGO gemeldet, lange her. Keinerlei Antwort.

Wenn ich mich recht erinnere geht es, wenn man statt Speed Power einstellt.
Mit dem technic-Hub geht das auch alles fehlerfrei.
Es betrifft fast alle Motoren L / XL, auch die angulars.

Wodran das liegt, kann man ohne Insiderinfos leider nicht wirklich beurteilen. Was ich mir auch vorstellen kann ist, dass es wegen der Sicherheit/maximalen Ausgabeleistung von AAA Batterien im Gegensatz zu AA Batterien Probleme gibt und dass es deshalb unterbunden ist. Aber das ist reine Spekulation.


LEGO's Elektronik Department stell ich mir so vor: 2 Leute in einem kleinen, feuchten Büro im Keller, mit denen niemand redet, weil sie 'anders' sind, so im 21.Jh leben und Internet können. Ich vermute die sind unterbesetzt und die Entscheider bei LEGO dicke alte Dänen die noch in den 80ern leben.

FAZIT - was machen mit dem kleinen PU-hub:

Ich hab mit Philo (philohome.com) und Balasz (racingbrick.com) darüber spekuliert und wir vermuten, dass die AAA batterien nicht genug Ampere liefern und der hub einfach "erstickst" weil der L-Motor fast alles zieht.
Philo meinte, ich solle mal NiMh Akkus probieren und kurz danach schickt mir jemand, der meine ECTO-1 Motorisierung (auch mit kleinem PU.hub) gekauft hatte ein video in dem er statt eine Medium einen L-Motor verwendet. Das Video ist von der Unterseite (damit ich auch sehe, dass es ein L ist ) und da man beim Ecto so schön von unten an die Baterien kommt hat er (wie ich empfehle) die Abdeckung des PU-Hub weggelassen.
Und was seh ich: Varta AAA NiMh rechargable.
Das würde obige Spekaulation untermauern. Zwar haben die NiMh Akkus nur 1,2 V angegeben, aber die normalen Alkalinen Batterien verlieren eh auch so schnenn Spannung, dass sie nach ner minute schon deutlich unter 1,5 V liegen, also scheinen Akkus einfach die Lösung zu sein.
Für Löter wie mich: Ich glaube ein 2-cell LIPO mit step up auf 9V würde da rein passen und mit dauerhaft 9V das meiste aus dem kleinen HUB rausholen.



reckless_glitch
05.06.2022, 10:56

Als Antwort auf den Beitrag von Lok24

Re: Ferngesteuerte DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

Lok24 hat geschrieben:

...
Lego verkauft das Krokodil mit App für genau die Gerätekombi, und funktioniert. Dnn kann es nicht bewusst unterbunden werden.
und es geht wohl auf wenn man statt "Speed" dsas Icon "Power" wählt.

Bei Eurobricks gibt es seitenlange Threads mit Messergebnissen dazu.

Hier mein Messaufaufbau:

[image]


Es geht genauso schief wenn man statt des Eingabemotors die Controller-Oberfläche der App nimmt.


WOW! Danke... Probier ich aus. Das könnte LEGO einem auch einfach antworten aber vermutlich wissen die selbst nicht wie dieses PU funktioniert



Lok24
05.06.2022, 12:32

Als Antwort auf den Beitrag von reckless_glitch

Re: Ferngesteuerte DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

Ich betreibe das auch nur mit Akkus, und der Fehler tritt nach 1sec Betrieb auf.
Und die Motoren ziehen mit "Speed" genausoviel Strom wie mit "Power".

Dazu schreibt Racingbricks:
And the problem is with the TachoMotorSpeed block, the MotorPower block works well with all hubs and motors.
https://www.eurobricks.co...mments#comment-3417428

Wenn es ein generelles Problem der Akkus/Stromstärke wäre würde das Kokodil mit der LEGO-SW nie fahren.
Das Problem wurde am 29.1.2020 von mir bei LEGO gemeldet.......



Lok24
05.06.2022, 12:35

Als Antwort auf den Beitrag von reckless_glitch

Re: Ferngesteuerte DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

reckless_glitch hat geschrieben:

WOW! Danke... Probier ich aus. Das könnte LEGO einem auch einfach antworten aber vermutlich wissen die selbst nicht wie dieses PU funktioniert


???? Ich bezweifle einfach, dass die Probleme vom Support bei den Entwicklern ankommen......
Wenn Du es probierst:
- mal die zwei Motoren tauschen, sollte gehen
- mal statt dem Speed-Icon das Power Icon nehmne, sollte gehen



tastenmann
06.06.2022, 18:51

Als Antwort auf den Beitrag von reckless_glitch

Re: Ferngesteuert: DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

reckless_glitch hat geschrieben:

Endlich gibt es einen vernünftigen DeLorean von LEGO
Nachdem ich schon den ECTO, die Tumbler und das 1989er Batmobil motorisiert hatte,
hab ich mir auf Verdacht den DeLorean am 1.4 im LEGO Laden gekauft und siehe da, es passen Motoren rein.

Powered up Motorisierung und Fernsteuerrung für den 10300 DeLorean

Es war eine ganz schöne Odyssee, herauszufinden, welche powered up Komponenten eigentlich zusammenpassen:
Den L-motor als antrieb mit nem kleinen powered up hub? vergesst es, der Hub hängt sich auf, vermutlich, weil der L-Motor zu viel Strom zieht für die AAA Bateriien im hub. Der bräuchte wohl lipos.
Jedenfalls hab ich es dann mit dem Buwizz und 2x Large Motor gelöst.



Was für eine cooler Umbau!
Das Set an sich gefällt mir schon gut, aber eigentlich hätte es Lego direkt so bringen können. Finde es gut, dass du die Flügeltüren "repariert" hast.

Viele Grüße
Tastenmann


Mehr Fotos gibt es auf Flickr
und auf Instagram


reckless_glitch
10.06.2022, 18:43

Als Antwort auf den Beitrag von Lok24

Re: Ferngesteuerte DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

Lok24 hat geschrieben:
Ich betreibe das auch nur mit Akkus, und der Fehler tritt nach 1sec Betrieb auf.
Und die Motoren ziehen mit "Speed" genausoviel Strom wie mit "Power".

Mist! Ich hatte schwer auf die Akkus gehofft.
Lok24 hat geschrieben:
Wenn Du es probierst:- mal die zwei Motoren tauschen, sollte gehen

nein, wieso, sind doch beides L-Motoren, oder meinst du ein Hub-Ausgang ist besser zum Gas geben?
Lok24 hat geschrieben:
- mal statt dem Speed-Icon das Power Icon nehmne, sollte gehen

Ich arbeite bei den "Autos" nur mit den verschiedenen Power icons, exakter speed ist mir egal, einfach Saft quasi.
Lok24 hat geschrieben:
Dazu schreibt Racingbricks:
And the problem is with the TachoMotorSpeed block, the MotorPower block works well with all hubs and motors.
https://www.eurobricks.co...omment-3417428

Mit Balasz von racingbricks hab ich geschrieben, da kam u.a. die idee mit der überlastung her.
Lok24 hat geschrieben:
Wenn es ein generelles Problem der Akkus/Stromstärke wäre würde das Kokodil mit der LEGO-SW nie fahren.

Das ist ein wichtiger Punkt!

Und dem bin ich nachgegangen. Und siehe da, mit der krokodilsteuerrung fährt der DeLorean. Aber warum? Ganz einfach:

Bei der normalen vorwärts-rückwärts-steuerung über einen Slider kann ich binnen Sekundenbruchteilen von voll vorwärts auf voll rückwärts schalten -> maximale Vollast wenn der Wagen rollt -> maximaler Stromfluss -> Hub geht in die knie.

Beim krokodil muss ich im interface an Drehreglern kurbeln und so dauert es viel länger um von voll vorwärts auf voll rückwärts zu schalten -> läuft! (Super Trick, LEGO!) Deshalb haben die wohl so viele Züge und keine Autos!

Lösung
Ich hatte damit schonmal angefangen, die änderrung des slider output ein wenig zu dämpfen, bevor ich ihn in den Motor patche, damit die Änderrung nicht zu stark ist, aber vielleicht brauche ich auch noch einen "schalthebel" mit Vorwärts, rückwärts, der nur im stand funktioniert um ein schnelles umschalten zu verhindern. Vielleicht benutzt die Krokodilsteuerrung auch das ausrollen der Motoren.

Was auch noch ein Problem werden könnte, ist, dass das Kokodil nur einen L-Motor hat, Der Delorean aber noch einen Lenkmotor, aber der sollte nicht zu viel ziehen.
Ich bin jedenfalls heute mit der Krokodilsteuerrung und übersetzung Motor->Räder 2:1 problemlos einige male male vor und zurück gefahren. Danke für den Tip.



Lok24
11.06.2022, 10:01

Als Antwort auf den Beitrag von reckless_glitch

Re: Ferngesteuerte DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

reckless_glitch hat geschrieben:

Lok24 hat geschrieben:
Wenn Du es probierst:- mal die zwei Motoren tauschen, sollte gehen

nein, wieso, sind doch beides L-Motoren, oder meinst du ein Hub-Ausgang ist besser zum Gas geben?

Nein ich meinte mein Bespiel im Video.

reckless_glitch hat geschrieben:
Lok24 hat geschrieben:
- mal statt dem Speed-Icon das Power Icon nehmne, sollte gehen

Ich arbeite bei den "Autos" nur mit den verschiedenen Power icons, exakter speed ist mir egal, einfach Saft quasi.

Sicher? Das hier ist das TachoMotor Speed

[image]


und das hier das Motor Power

[image]


Das erste führt zu dem Fehler, das zweite nicht. Bei mir und anderen.

reckless_glitch hat geschrieben:
Lok24 hat geschrieben:
Wenn es ein generelles Problem der Akkus/Stromstärke wäre würde das Kokodil mit der LEGO-SW nie fahren.

Das ist ein wichtiger Punkt!
Und dem bin ich nachgegangen. Und siehe da, mit der krokodilsteuerrung fährt der DeLorean. Aber warum? Ganz einfach:

Bei der normalen vorwärts-rückwärts-steuerung über einen Slider kann ich binnen Sekundenbruchteilen von voll vorwärts auf voll rückwärts schalten -> maximale Vollast wenn der Wagen rollt -> maximaler Stromfluss -> Hub geht in die knie.
Alles längst probiert. Eventuell hat sich der Fehler inzwischen geändert, es gab ja etlich FW-Upgrades.

Welches Icon nutzt Du tatsächlich?



reckless_glitch
23.06.2022, 17:08

Als Antwort auf den Beitrag von reckless_glitch

Re: Ferngesteuert: DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

Ich habe dich schon verstanden. Ich benutze auch Balazs' PU Dokumentation - da sind ja deine Bilder her - als einzige mir bekannte Quelle. (Wow ich habe ein legales Genitiv-Apostroph in einem deutschen Forum gesetzt )

Aber (no offense) ich sag's gern nochmal und mein's genau so: Ich nehme für 'Autos', also primitive Fahrzeuge, immer nur die Power (vermutl. Stromstärke) Blöcke, also den power-loop

[image]



oder den power block wenn der loop komplexer wird

[image]



mir ist gerade aufgefallen, der all inclusive loop heisst bei racingbrick "ContinuousMediumMotor ControlSpeedSteering"
Also ist laut namen nicht für Ls gedacht...

Jedenfalls habe ich bei meinen tests bemerkt, schnelles ändern der "Power" bei hoher aktueller Geschwindigkeit ist der Knackpunkt.
Ich glaube immernoch, dass der Strom beim Abbremsen (oder gar Richtung wechseln) beim L so hoch wird, dass der Hub erstickt und dann irgendwas intern fehlfunktioniert bis zu einem hard reset (batterien raus).
PU-programmierung nervt, aber ich glaube ein separater rückwärtsgang und ein dämpfen des inputs werden helfen.



Lok24
23.06.2022, 17:13

Als Antwort auf den Beitrag von reckless_glitch

Re: Ferngesteuert: DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

Alles klar, wollte nur nochmal sicher gehen,
ich kann ja nur berichten was ich so für Erfahrungen gemacht und was bei Eurobricks so steht.
Schreib mal, wenn Du eine Lösung hast.



reckless_glitch
23.06.2022, 21:43

Als Antwort auf den Beitrag von reckless_glitch

Re: Ferngesteuert: DeLorean 10300 (Zeitmaschine aus zurück in die Zukunft)

ich hab grad was gebprogramierbastelt:

vom speed slider werden nur werte >0 an den motor als "power" weitergegeben.
negative werte werden 0 gesetzt (quasi gaspedal)

Dann dazu einen butten, der nur wenn der gemessene Motorspeed =0 ist
die richtung (vor rück) wechselt (quasi Schalthebel).

Ist der speed >0, setzt er kurz die power runter, macht ein fieses geräusch (überlagerrung aus dielenknarren und trockenene furzgeräusch)
und setzt die power wieder rauf - damit man auch weis dass man was falsch macht. (quasi der mislungene versuch zu schalten)
aber er dreht die power nie direkt um!
Hätte nie gedacht, dass ich diese blöden Geräusche mal verwende, vor allem diese schiachen*** Furzgeräusche.

Jedenfalls, das wird helfen, aber meiner erfahrung nach noch nicht ganz reichen.
Ich muss den slider input noch zusätzlich etwas dämpfen, wenn der wert runter geht.
Vermutlich ein herabsetzen um einen gewissen maximalwert (sowas wie 10%)
und dann ein delay (sowas wie 0.1 s) im loop.
muss ich am L-Motor ausprobieren, aber ich bin zuversichtlich.


***(schiach, österr. für hässlich/widerlich, gesprochen mit ch wie in doch, bestes Wort von drüben!)



Gesamter Thread: