Lok24
06.07.2020, 15:17

Editiert von
Lok24
06.07.2020, 16:30

+9Powered Up Firmware Update

Hallo zusammen,

da gibt es in letzter Zeit einige Irritationen mit der Firmware, aber es gibt dafür auch eine Erklärung und eine Lösung.

Ben® hat geschrieben:

3) zu meinem Erstaunen zeigte die App das Kroko, den Disney-Zug und das Bat-Auto. Die App hatte ich gewiss über ein Jahr nicht mehr in Betrieb. Muss sich also irgendwann selbst runderneuert haben (teils gut, teils zeigt es das Dilemma dieses Smartgedöns: es macht was seine wahren Herren wollen).


Du kannst bei Android für jede einzelne App das automatische Update ausschalten, sie bleiben dann ewig auf dem letzten Stand.
Aber Du siehst dann natürlich auch die neuen Funktionen nicht.
Man kann übrigens auch WLAN ausschalten, die Apps laufen trotzdem.

Ben® hat geschrieben:
4) nach Anstarten sah ich auch den "Führerstand" des Krokos. Beim Versuch per Bluetooth den (das?) Hub mit angehängtem Technic-Motor anzusteuern, ging dann der Ärger los: erst blinkte das Hub immer nur ohne sich zu verbinden. Irgendwann teilte das Smartphone mit, da sei jetzt was schiefgegangen und verlangte einen Neustart.

6) Ernüchterung setzte ein, als offenbar neue Firmware aufs Hub aufgespielt werden musste: Wartezeit ca. 20 Minuten?

7) Bei Inbetriebnahme wieder die Fehlermeldung "Ups - da ist was schiefgelaufen". => Neustart => Neuverbindung => Upgrade Firmware (?): Wartezeit abermals gut 20 Minuten!


Tja. So ist das wohl

Erstmal: Die App enthält die App selbst und die neuste Firmware für das Hub (neuerdings enthält wohl auch die Powered Up App die Firmware für das Technic-Hub)

Wenn die App feststellt dass sie einen neuere FW als das Hub hat möchte sie die da draufladen (ich weiß aber nicht ob sie fragt?).

Der Bootloader

Letztlich stecken in dem Hub zwei Dinge: die Firmware, die man updaten kann, und der sogenannte „Bootloader“, das ist ein fest(!!!) eingebautes Programm, dass die FW von der App (oder sonstwo) in Empfang nimmt und in das Hub lädt.

Diesen Bootloader kann man auch künstlich provozieren: das Hub aus(!)schalten.
Grüne Taste drücken, bis LED lila blinkt. Jetzt wird beim Starten der App die FW neu geladen.
Das dauert ca. 90 sec beim Hub 88009, es blinkt lustig rot/grün/blau, und der Fortschritt wird im Sekundentakt in% auf dem Display angezeigt.
(das soll nicht bedeuten dass ich an Deinen 20Min zweifle, aber bei mir geht es ratzfatzt)

Der Fehler

Leider hat der Bootloader des Hub 88009 einen Fehler! Und da der Bootloader ja fest eingebaut ist kann man den auch nicht beseitigen.
Das hat man nie gemerkt, weil LEGO ja immer nur die „dummen“ Motoren, also Train-Motor und WeDo Motor, in den Sets hatte.
Jetzt hat man in das Krokodil einen Technic Motor mit Rückmeldung gepackt – und schon ist der Bootloader ratlos.

Das teuflische: er macht die LED aus, aber das Hub läuft „aufgehängt“ weiter!

Die Lösung

1.) App schließen
2.) alle Motoren und Sensoren vom Hub abziehen
3.) Batterien raus
4.) Batterien rein
5.) Grüne Taste bis LED lila blinkt
6.) App starten

Hoffe das hilft dem einen oder anderen weiter.
Über Rückmeldungen ob das so funktioniert hat würde ich mich freuen.

Disclaimer: Ja, natürlich müsste DIE FIRMA das ordentlich kommunizieren.
Und ja, natürlich, ein Kinderspielzeug sollte funktionieren, basta.
Und last not least: Don’t kill the messenger


Grüße

Werner



Thomas52xxx , Dirk1313 , Ben® , tmctiger , tobb , AdmiralStein , JuL , Saori , rgbs gefällt das (9 Mitglieder)


6 vorhergehende Beiträge sind ausgeblendet

Alle anzeigen Immer alle anzeigen Beitragsbaum

Dirk1313
12.10.2021, 14:56

Als Antwort auf den Beitrag von rgbs

Re: Powered Up Firmware Update

rgbs hat geschrieben:

Lok24 hat geschrieben:


Hat mit LEGO nicht direkt zu tun, die Eigenschaft haben alle elektronischen Geräte.
Der Bootloader ist halt nicht optimal, aber die Eigenschaft eines solchen Programms ist es eben, fest eingebaut zu sein.

Das geht jetzt nicht gegen Dich, nochmals danke für Deinen Tipp, aber warum zum Donner schafft es TLC nicht, mir für 85€ eine Lösung für die Motorisierung meines Krokodils zu liefern, die problemlos und ohne "Klimmzüge" funktioniert.

Gruß
R.G.


Ihr habt beide Recht (Werner und Du).
Wer vorhandene Hardware mit dem „neuen“ Set nutzen möchte, muss sich mit dem Fehler wohl abfinden.
ABER LEGO könnte natürlich mit neuer Hardware(version) den „Fehler“ beheben. Sie könnten auch ein Bundle aus neuer Hub-Version, Motor und Krokodil anbieten - sowas hats ja früher auch schon gegeben.


Viele Grüße
Dirk - Mail

[image]


Events 2021: BricksLA (9-10.1.) - Brickvention (16.-17.1.) - PdC Online Fanweekend (19.-20.06.) - Skaerbaek Fanweekend (25.-26.09.) - SteinCHenWelt (09.-10.10.) - BrickingBavaria (05.-07.11.)


Lok24
12.10.2021, 15:05

Als Antwort auf den Beitrag von Dirk1313

+1Re: Powered Up Firmware Update

Dirk1313 hat geschrieben:

ABER LEGO könnte natürlich mit neuer Hardware(version) den „Fehler“ beheben.

Ja, aber ich kann nicht beurteilen, ob sie das nicht schon tun....



Dirk1313 gefällt das


rgbs
12.10.2021, 18:42

Als Antwort auf den Beitrag von Lok24

Editiert von
rgbs
12.10.2021, 18:55

Re: Powered Up Firmware Update

Lok24 hat geschrieben:


Ja, aber ich kann nicht beurteilen, ob sie das nicht schon tun....

Also ich habe sowohl den Hub als auch den Motor vor einer Woche bei LEGO gekauft und auf meinem Android Tablet ist PoweredUp 3.7.0 installiert.

Gruß
R.G.



Technicmaster0
13.10.2021, 12:11

Als Antwort auf den Beitrag von Lok24

Re: Powered Up Firmware Update

Lok24 hat geschrieben:

Ja, aber ich kann nicht beurteilen, ob sie das nicht schon tun....

Ich denke, dass so ein Bootloader durch deutlich mehr interne Stufen gehen muss, als ein normales Firmware Update. Wenn der Bootloader mal einen wirklich schlimmen Fehler haben sollte, müssen die Hubs ausgetauscht werden. Deshalb wird sowas nur sehr ungerne und selten aktualisiert.
Soweit ich weiß, hat das was mit UART-Geräten, also Sensoren und "schlauen" Motoren zu tun. Aber ich hab das jetzt nicht genauer getestet.



Lok24
13.10.2021, 14:00

Als Antwort auf den Beitrag von Technicmaster0

Re: Powered Up Firmware Update

Technicmaster0 hat geschrieben:

...also Sensoren und "schlauen" Motoren zu tun. Aber ich hab das jetzt nicht genauer getestet.

Hab jetzt noch mal ein bißchen rumgespielt, bei mir ist es so, dass alles(!) geht, wenn am Port A ein Dummer Motor hängt oder der Port unbelegt ist. Schlaue Motoren oder Sensoren (im Test: Boost-Motor und Sensor, technic L) an Port B stören nicht.



Lok24
13.10.2021, 14:09

Als Antwort auf den Beitrag von Technicmaster0

Editiert von
Lok24
13.10.2021, 14:18

Re: Powered Up Firmware Update

Technicmaster0 hat geschrieben:

Soweit ich weiß, hat das was mit UART-Geräten, also Sensoren und "schlauen" Motoren zu tun. Aber ich hab das jetzt nicht genauer getestet.

Kannst Du das denn mit der powered Up App 3.7.0 nochmal testen? Ob die dazu auffordert, die Motoren abzuziehen?



rgbs
13.10.2021, 15:24

Als Antwort auf den Beitrag von Lok24

Editiert von
rgbs
13.10.2021, 15:33

Re: Powered Up Firmware Update

Hallo Werner,

ich bin ja mit PowerdUp 3.7.0 auf den Hammer gelaufen. Wäre da der Hinweis gekommen, den Motor abzuziehen, hätte ich ja nicht 2 Stunden "geübt".
Ob nun eine Macke im Bootloader oder was ich eher vermute im Firmwareloader ist, ist mir egal.
Ich erwarte einfach, dass etwas, was ich bei TLC kaufe problemlos funktioniert.
Das gemeine ist doch, bei Control+ muss man am Hub alles anstecken, damit es geht, und hier war es halt anders.

Gruß
R.G.



Lok24
13.10.2021, 15:34

Als Antwort auf den Beitrag von rgbs

Editiert von
Lok24
13.10.2021, 15:35

Re: Powered Up Firmware Update mit Video

Hallo,

rgbs hat geschrieben:

ich bin ja mit PowerdUp 3.0.7 auf den Hammer gelaufen. Wäre da der Hinweis gekommen, den Motor abzuziehen, hätte ich ja nicht 2 Stunden "geübt".

Ich kann ja nicht wissen was Du machst
Wenn Du den Bootloader manuell aufrufst kann nie eine Meldung kommen, wenn Du aber das Hub einschaltest und mit der App verbindest könnte(!) eine kommen, andere schrieben sowas, kann aber auch eine Ente sein.

rgbs hat geschrieben:
Das gemeine ist doch, bei Control+ muss man am Hub alles anstecken, damit es geht, und hier war es halt anders.

Eine urbane Legende.....
1.) Powered Up App für das technic hub verwenden oder
2.) den Bootloader manuell aufrufen

https://www.doctor-brick....der.15215/#post-274117



rgbs
13.10.2021, 15:57

Als Antwort auf den Beitrag von Lok24

Re: Powered Up Firmware Update mit Video

Lok24 hat geschrieben:

Hallo,

Eine urbane Legende.....
1.) Powered Up App für das technic hub verwenden oder


Das würde ich auch nie tun.

Und zur Sache mit dem Bootloader: Ein Bootloader sorgt dafür, dass ein System überhaupt hochfährt (bootet). Wenn es also eine "Macke" im Bootloader wäre, könnte ich das System nie mit angestecktem Motor starten.

Gruß
R.G.



Lok24
13.10.2021, 16:07

Als Antwort auf den Beitrag von rgbs

Editiert von
Lok24
13.10.2021, 16:15

Re: Powered Up Firmware Update mit Video

rgbs hat geschrieben:

Lok24 hat geschrieben:

1.) Powered Up App für das technic hub verwenden oder
Das würde ich auch nie tun.

Warum nicht? Dann gehst Du dem ganzen Unfug welche Kabel wo angesteckt sein müssen aus dem Weg. Mache ich immer so.
Aber, wie das Video zeigt, es geht ja auch mit der control+ App.
Und der Fehler steckt nur im City-Hub.

rgbs hat geschrieben:
Und zur Sache mit dem Bootloader: Ein Bootloader sorgt dafür, dass ein System überhaupt hochfährt (bootet). Wenn es also eine "Macke" im Bootloader wäre, könnte ich das System nie mit angestecktem Motor starten.

Der LEGO-Bootloader ist nur das Programm, das die Firmware in das Hub lädt.
Du erkennst das daran, dass in der Powered Up App im Bootloader-Modus "LEGO Bootloader" statt des Hub-Namens steht.



3 nachfolgende Beiträge sind ausgeblendet

Alle anzeigen Immer alle anzeigen

Gesamter Thread: