Lok24
06.07.2020, 15:17

Editiert von
Lok24
06.07.2020, 16:30

+9Powered Up Firmware Update

Hallo zusammen,

da gibt es in letzter Zeit einige Irritationen mit der Firmware, aber es gibt dafür auch eine Erklärung und eine Lösung.

Ben® hat geschrieben:

3) zu meinem Erstaunen zeigte die App das Kroko, den Disney-Zug und das Bat-Auto. Die App hatte ich gewiss über ein Jahr nicht mehr in Betrieb. Muss sich also irgendwann selbst runderneuert haben (teils gut, teils zeigt es das Dilemma dieses Smartgedöns: es macht was seine wahren Herren wollen).


Du kannst bei Android für jede einzelne App das automatische Update ausschalten, sie bleiben dann ewig auf dem letzten Stand.
Aber Du siehst dann natürlich auch die neuen Funktionen nicht.
Man kann übrigens auch WLAN ausschalten, die Apps laufen trotzdem.

Ben® hat geschrieben:
4) nach Anstarten sah ich auch den "Führerstand" des Krokos. Beim Versuch per Bluetooth den (das?) Hub mit angehängtem Technic-Motor anzusteuern, ging dann der Ärger los: erst blinkte das Hub immer nur ohne sich zu verbinden. Irgendwann teilte das Smartphone mit, da sei jetzt was schiefgegangen und verlangte einen Neustart.

6) Ernüchterung setzte ein, als offenbar neue Firmware aufs Hub aufgespielt werden musste: Wartezeit ca. 20 Minuten?

7) Bei Inbetriebnahme wieder die Fehlermeldung "Ups - da ist was schiefgelaufen". => Neustart => Neuverbindung => Upgrade Firmware (?): Wartezeit abermals gut 20 Minuten!


Tja. So ist das wohl

Erstmal: Die App enthält die App selbst und die neuste Firmware für das Hub (neuerdings enthält wohl auch die Powered Up App die Firmware für das Technic-Hub)

Wenn die App feststellt dass sie einen neuere FW als das Hub hat möchte sie die da draufladen (ich weiß aber nicht ob sie fragt?).

Der Bootloader

Letztlich stecken in dem Hub zwei Dinge: die Firmware, die man updaten kann, und der sogenannte „Bootloader“, das ist ein fest(!!!) eingebautes Programm, dass die FW von der App (oder sonstwo) in Empfang nimmt und in das Hub lädt.

Diesen Bootloader kann man auch künstlich provozieren: das Hub aus(!)schalten.
Grüne Taste drücken, bis LED lila blinkt. Jetzt wird beim Starten der App die FW neu geladen.
Das dauert ca. 90 sec beim Hub 88009, es blinkt lustig rot/grün/blau, und der Fortschritt wird im Sekundentakt in% auf dem Display angezeigt.
(das soll nicht bedeuten dass ich an Deinen 20Min zweifle, aber bei mir geht es ratzfatzt)

Der Fehler

Leider hat der Bootloader des Hub 88009 einen Fehler! Und da der Bootloader ja fest eingebaut ist kann man den auch nicht beseitigen.
Das hat man nie gemerkt, weil LEGO ja immer nur die „dummen“ Motoren, also Train-Motor und WeDo Motor, in den Sets hatte.
Jetzt hat man in das Krokodil einen Technic Motor mit Rückmeldung gepackt – und schon ist der Bootloader ratlos.

Das teuflische: er macht die LED aus, aber das Hub läuft „aufgehängt“ weiter!

Die Lösung

1.) App schließen
2.) alle Motoren und Sensoren vom Hub abziehen
3.) Batterien raus
4.) Batterien rein
5.) Grüne Taste bis LED lila blinkt
6.) App starten

Hoffe das hilft dem einen oder anderen weiter.
Über Rückmeldungen ob das so funktioniert hat würde ich mich freuen.

Disclaimer: Ja, natürlich müsste DIE FIRMA das ordentlich kommunizieren.
Und ja, natürlich, ein Kinderspielzeug sollte funktionieren, basta.
Und last not least: Don’t kill the messenger


Grüße

Werner



Thomas52xxx , Dirk1313 , Ben® , tmctiger , tobb , AdmiralStein , JuL , Saori , rgbs gefällt das (9 Mitglieder)


mackj1
18.02.2021, 19:26

Als Antwort auf den Beitrag von Lok24

Re: Powered Up Firmware Update

Sorry, bin komplett neu: habe auch das Krokodil mit dem starken Lego-Technik Motor. Die Symptome sind wie hier beschrieben, allerdings läuft das Update wohl bei jedem Start neu rein. Lässt sich das vermeiden? Ich verwende die Ldgo App um das Krokodil zu steuern. Danke!



Lok24
19.02.2021, 10:05

Als Antwort auf den Beitrag von mackj1

Re: Powered Up Firmware Update

Hallo,

nein, das ist nicht normal.

Das FW-Update läuft
- wenn die App eine neuere Version enthält als das Hub
- die FW auf dem Hub nicht funktioniert
- das Hub im Bootloader-Modus ist

Du schaltest das Hub nur ein, sodass es blinkt, und hälst nicht etwa den Einschalter gedrückt, bis es lila blinkt?
Läuft denn alles, wenn es mal gestartet ist?
Eigentlich sollte das Hub sich völlig totstellen, da Du ja den Motor dran hast?

App mal gelöscht und neu installiert?



rgbs
12.10.2021, 05:10

Als Antwort auf den Beitrag von Lok24

Editiert von
rgbs
12.10.2021, 05:16

+1Re: Powered Up Firmware Update

Hallo Werner,

danke für den Tipp, den Motor abzuziehen. Ich war schon rund zwei Stunden am "kämpfen".
LEGO hat doch nicht mehr alle Latten am Zaun.

Gruß
R.G.



Ben® gefällt das


Lok24
12.10.2021, 07:36

Als Antwort auf den Beitrag von rgbs

Editiert von
Lok24
12.10.2021, 07:47

Re: Powered Up Firmware Update

rgbs hat geschrieben:

Ich war schon rund zwei Stunden am "kämpfen".
LEGO hat doch nicht mehr alle Latten am Zaun.



Hat mit LEGO nicht direkt zu tun, die Eigenschaft haben alle elektronischen Geräte.
Der Bootloader ist halt nicht optimal, aber die Eigenschaft eines solchen Programms ist es eben, fest eingebaut zu sein.



rgbs
12.10.2021, 09:29

Als Antwort auf den Beitrag von Lok24

+1Re: Powered Up Firmware Update

Lok24 hat geschrieben:



Hat mit LEGO nicht direkt zu tun, die Eigenschaft haben alle elektronischen Geräte.
Der Bootloader ist halt nicht optimal, aber die Eigenschaft eines solchen Programms ist es eben, fest eingebaut zu sein.

Das geht jetzt nicht gegen Dich, nochmals danke für Deinen Tipp, aber warum zum Donner schafft es TLC nicht, mir für 85€ eine Lösung für die Motorisierung meines Krokodils zu liefern, die problemlos und ohne "Klimmzüge" funktioniert.

Gruß
R.G.



Ben® gefällt das


Lok24
12.10.2021, 13:33

Als Antwort auf den Beitrag von rgbs

+1Re: Powered Up Firmware Update

rgbs hat geschrieben:

Das geht jetzt nicht gegen Dich, nochmals danke für Deinen Tipp, aber warum zum Donner schafft es TLC nicht, mir für 85€ eine Lösung für die Motorisierung meines Krokodils zu liefern, die problemlos und ohne "Klimmzüge" funktioniert.


Es steht in meinem anderen Beitrag, aber ich schreibe gerne nochmal wie ich das sehe (nicht um die Fa. in Schutz zu nehmen, sondern um zu erklären, warum das m.E. nicht geht)

Alle Motoren (und Sensoren) haben sog. IDs (interne Nummern), mit denen sie sich am Hub melden. Damit das weiß was wo steckt.
Das Hub hat die Bootloader fest "eingebrannt".

So.

"Damals" als das City Hub rauskaum gab es den Boost-Motor, den Zugmotor und den WeDo M Motor.
Da war (m.W.) die Welt noch in Ordnung.
Und danach kamen die technic-Motoren (mit andern ID's), und damit hat der Bootloader nicht gerechnet - das Hub stürzt ab. Da der Bootloader aber fest ist (was ein Segen ist, man kann ihn nicht kaputtspielen) kann die Firma das nicht reparieren.
Und deswegen hast Du das Problem.

Aber: die FW die Du jetzt aufgespielt hast (3.7.0) berücksicht das, wenn ich es richtig verstanden habe, und wenn es "normal" ein Update gibt wird man aufgefordert, die Motoren zu entfernen.

So meine Idee, warum das alles so ist.



rgbs gefällt das


Dirk1313
12.10.2021, 14:56

Als Antwort auf den Beitrag von rgbs

Re: Powered Up Firmware Update

rgbs hat geschrieben:

Lok24 hat geschrieben:


Hat mit LEGO nicht direkt zu tun, die Eigenschaft haben alle elektronischen Geräte.
Der Bootloader ist halt nicht optimal, aber die Eigenschaft eines solchen Programms ist es eben, fest eingebaut zu sein.

Das geht jetzt nicht gegen Dich, nochmals danke für Deinen Tipp, aber warum zum Donner schafft es TLC nicht, mir für 85€ eine Lösung für die Motorisierung meines Krokodils zu liefern, die problemlos und ohne "Klimmzüge" funktioniert.

Gruß
R.G.


Ihr habt beide Recht (Werner und Du).
Wer vorhandene Hardware mit dem „neuen“ Set nutzen möchte, muss sich mit dem Fehler wohl abfinden.
ABER LEGO könnte natürlich mit neuer Hardware(version) den „Fehler“ beheben. Sie könnten auch ein Bundle aus neuer Hub-Version, Motor und Krokodil anbieten - sowas hats ja früher auch schon gegeben.


Viele Grüße
Dirk - Mail

[image]


Lok24
12.10.2021, 15:05

Als Antwort auf den Beitrag von Dirk1313

+1Re: Powered Up Firmware Update

Dirk1313 hat geschrieben:

ABER LEGO könnte natürlich mit neuer Hardware(version) den „Fehler“ beheben.

Ja, aber ich kann nicht beurteilen, ob sie das nicht schon tun....



Dirk1313 gefällt das


rgbs
12.10.2021, 18:42

Als Antwort auf den Beitrag von Lok24

Editiert von
rgbs
12.10.2021, 18:55

Re: Powered Up Firmware Update

Lok24 hat geschrieben:


Ja, aber ich kann nicht beurteilen, ob sie das nicht schon tun....

Also ich habe sowohl den Hub als auch den Motor vor einer Woche bei LEGO gekauft und auf meinem Android Tablet ist PoweredUp 3.7.0 installiert.

Gruß
R.G.



10 nachfolgende Beiträge sind ausgeblendet

Alle anzeigen Immer alle anzeigen

Gesamter Thread: